handmade.network » Forums » Site Feedback » [FIXED] Cannot change background image in project submission
lost
Lost Astronaut Studios
4 posts
1 project

On Handmade IRC: /nick "sacrebleu"
Programmer, Artist, Scientist, Niceguy
Owner: lostastronaut.com

#10307 [FIXED] Cannot change background image in project submission
4 months, 2 weeks ago Edited by Jeroen van Rijn on Jan. 9, 2017, 11:12 p.m. Reason: fixed

Hey I uploaded a background image and then couldn't re-upload a modified version even tho filename was different
lost
Lost Astronaut Studios
4 posts
1 project

On Handmade IRC: /nick "sacrebleu"
Programmer, Artist, Scientist, Niceguy
Owner: lostastronaut.com

#10308 [BUG] Cannot change background image in project submission
4 months, 2 weeks ago

Seems to be partially an image caching issue. There is a way to fix this by informing the browser that the image, despite having the URI, is newer information that in the browser cache. Similar problem on profile page. (Chrome, Windows 10)
Kelimion
Jeroen van Rijn
211 posts
3 projects

A big ball of Wibbly-Wobbly, Timey-Wimey _stuff_

#10309 [BUG] Cannot change background image in project submission
4 months, 2 weeks ago Edited by Jeroen van Rijn on Jan. 9, 2017, 8:50 p.m. Reason: confirmed as a regression

Indeed, confirmed.

We're currently simplifying the backend in preparation for the site leaving beta. Until that time, some regressions may occur. (Like for example the double escaping of the blurb under your name…)
I'll have a look at why this is tomorrow. I'm presently in the middle of another feature.

Replacing or deleting a project background should work as intended again sometime tomorrow or wednesday, depending on your timezone. I'll add the file hash as a cachebuster. I'll drop you a line when it's done.

Welcome to the community and thanks for the report.
Kelimion
Jeroen van Rijn
211 posts
3 projects

A big ball of Wibbly-Wobbly, Timey-Wimey _stuff_

#10311 [BUG] Cannot change background image in project submission
4 months, 2 weeks ago

These should now be fixed again. I put a temporary cache buster into place, to be replaced with a more robust one before the end of beta.