Handmade Network»Forums
11 posts
Problem having 4coder use bat file in a different directory
Edited by baublebeard on Reason: formatting

I'm trying to get 4coder set up for the first time, just getting a little hello world program going. I'm trying to get it to pick up a build.bat file in different directory and my folder structure is this:

C:\dev\hello4coder\project.4coder C:\dev\hello4coder\code\build.bat

and below is my project.4coder file

version(2);
project_name = "helloworld.exe";
patterns = {
"*.c",
"*.cpp",
"*.h",
"*.m",
"*.bat",
"*.sh",
"*.4coder",
};
blacklist_patterns = {
".*",
};
load_paths_base = {
 { ".", .relative = true, .recursive = true, },
};
load_paths = {
 .win = load_paths_base,
 .linux = load_paths_base,
 .mac = load_paths_base,
};

commands = {
 .build = { .out = "*compilation*", .footer_panel = true, .save_dirty_files = true,
   .win = "code\\build.bat",
   },
 .run = { .out = "*run*", .footer_panel = false, .save_dirty_files = false,
   .win = "build\\helloworld.exe",
   },
};
fkey_command = {
.F1 = "build";
.F2 = "run";
};

It was working if build.bat is in the same directory but won't find it otherwise. I save the file and run load_project each time I tweak the path.

Simon Anciaux
1260 posts
Problem having 4coder use bat file in a different directory

Maybe this will help: https://4coder.handmade.network/forums/t/8395/p/26210

11 posts
Problem having 4coder use bat file in a different directory
Edited by baublebeard on Reason: missing words

Thanks! I'll try that out but ended up getting it to work by swapping to version(1) for the project file. However version 2 got generated by setup_new_project was bugging out syntax wise for load_project and that's why it wasn't getting loaded.