handmade.network » Forums » Site Feedback » Blog post without comment
mrmixer
Simon Anciaux
468 posts
#15824 Blog post without comment
3 months ago Edited by Simon Anciaux on July 21, 2018, 3:19 p.m. Reason: Initial post

When I come to the site using the rss feed, sometimes the comments of a blog post are not visible.
It seems that there can be several links to a post, one with comment and one without. For example:
This link is /blogs/p/3264
This link is /blogs/p/3263
Is it on purpose ?
insofaras
Alex Baines
40 posts / 1 project
#15825 Blog post without comment
3 months ago

Looks like this instance could have been an accidental double-post by Allen.
The two entries are also visible here: https://4coder.handmade.network/blog and have slightly different text.

I'll let him know, and make a note to investigate further in case something screwed up server-side to cause it.

Do you have other examples where there are multiple links to a blog like this, or is this the only one?
mrmixer
Simon Anciaux
468 posts
#15827 Blog post without comment
3 months ago

Oh I didn't saw the double post on the blog page.
No I don't have another example. It happened once before, but I didn't looked into it and it was probably that someone had posted a comment while I was reading.
Mr4thDimention
Allen Webster
422 posts / 2 projects

Heyo

#15830 Blog post without comment
2 months, 4 weeks ago

insofaras
Looks like this instance could have been an accidental double-post by Allen.
The two entries are also visible here: https://4coder.handmade.network/blog and have slightly different text.

I'll let him know, and make a note to investigate further in case something screwed up server-side to cause it.

Do you have other examples where there are multiple links to a blog like this, or is this the only one?


I was just headed over to report this myself. I don't think I did anything that *should* have caused it to double post. I did edit it like three or four times so the fact that they're different suggests to me one of the edits got posted as a separate post perhaps, but I don't feel like it should be possible to accidentally hit a button that causes an edit to be posted as a separate blog post right? I didn't edit it in a text file and then copy it in to post it, I typed it all up with the on-site editor, hit update preview a few times, and as far as I recall just hit Submit once.

I'll leave the duplicate up for as long as you want if it's helpful, but obviously I'd like to take it down when you're done inspecting it, so if someone could let me know how this bug is doing as you work on it that'd be great!
insofaras
Alex Baines
40 posts / 1 project
#15832 Blog post without comment
2 months, 4 weeks ago Edited by Alex Baines on July 22, 2018, 6:20 p.m.

Sounds like we need to take a closer look internally.

As you've said, just editing the post multiple times should never lead to it creating a new post, so there may well be a bug in the server-side logic that needs uncovering.

I've taken a snapshot of the DB to investigate with, so feel free to delete one of the two posts now -
we'll let you know if/when we discover anything.

EDIT: This is the sequence of events, seems the initial submission happened twice before the editing.
1
2
3
4
5
6
7
8
 ID  |  Created/Edited UTC  |    Reason
-----+----------------------+--------------
3263 | 21 Jul 2018 02:14:58 | Initial post
3264 | 21 Jul 2018 02:14:59 | Initial post
3264 | 21 Jul 2018 02:17:26 |
3264 | 21 Jul 2018 02:21:38 |
3264 | 21 Jul 2018 02:26:52 |
3264 | 21 Jul 2018 02:26:58 |

The reply by nj was on the 3263 post that hasn't received any edits, so to preserve the newest state the 3264 blog contents may need to be copy/pasted over to 3263, then 3264 deleted.