handmade.network » Forums » The Handmade.Network Feedback Megathread!
azmr
Andrew Reece
18 posts
1 project

Ergonomics student and maker of things

#6499 Avatar image not changing
1 year, 4 months ago Edited by Andrew Reece on April 26, 2016, 12:53 p.m.

Page URL: https://handmade.network/_settings#account

Description of issue: The account avatar image uploaded and was set nicely the first time, but when I tried to change it, on saving profile, the page reloads but doesn't update the avatar. I tried shift-F5, that didn't do anything. The file names of the 2 avatars were different. The page load seems to take slightly longer with a larger file, so it may be uploading...

Browser + version: Chrome Version 49.0.2623.112 m (64-bit)

Ascii Screenshot(s):
(Do I need to upload images somewhere else to link to them? Or can they just be uploaded here?)

After selecting an image:
1
2
3
        +-------------+
Avatar: | Choose File | NewImage.png
        +-------------+


After clicking SAVE PROFILE, and page loads, image below looks the same:
1
2
3
        +-------------+
Avatar: | Choose File | No file chosen
        +-------------+


EDIT: Ok, the new avatar is up for this post, but not for my previous post or on my profile/profile update pages.

EDIT2: I edited my short bio, and that change was reflected everywhere I looked.
Kelimion
Jeroen van Rijn
235 posts
3 projects

A big ball of Wibbly-Wobbly, Timey-Wimey _stuff_

#6500 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

azmr
Page URL: https://handmade.network/_settings#account

Description of issue: The account avatar image uploaded and was set nicely the first time, but when I tried to change it, on saving profile, the page reloads but doesn't update the avatar. I tried shift-F5, that didn't do anything. The file names of the 2 avatars were different. The page load seems to take slightly longer with a larger file, so it may be uploading...

Browser + version: Chrome Version 49.0.2623.112 m (64-bit)

Ascii Screenshot(s):
(Do I need to upload images somewhere else to link to them? Or can they just be uploaded here?)

After selecting an image:
1
2
3
        +-------------+
Avatar: | Choose File | NewImage.png
        +-------------+


After clicking SAVE PROFILE, and page loads, image below looks the same:
1
2
3
        +-------------+
Avatar: | Choose File | No file chosen
        +-------------+


EDIT: Ok, the new avatar is up for this post, but not for my previous post or on my profile/profile update pages.

EDIT2: I edited my short bio, and that change was reflected everywhere I looked.


We may still need to finetune caching behaviour, which is what it looks like this is about.
As for uploading images. Support for forum + blog attachments will be landing in the short term, probably sometime next week.
mmozeiko
Mārtiņš Možeiko
1477 posts
1 project
#6508 The Handmade.Network Feedback Megathread!
1 year, 4 months ago Edited by Mārtiņš Možeiko on April 26, 2016, 6:59 p.m.

Something is wrong with your URL scheme.
Some links lead to https://hmn.handmade.network/... but some links lead to https://handmade.network/... I think I was logged in on hmn.handmade.network site, but not on handmade.network site and it was strange. When going over pages suddenly I'm logged in, and after few links I'm logged out, and a bit later I'm logged in again. Very confusing.

Oh, and you really need to serve http://handmade.network/static/light/empty-avatar.svg image from https address. Otherwise no green padlock on address bar. Don't make absolute URL's. Make them relative to root or a least to protocol: //handmade.network/static/light/empty-avatar.svg
TimRex
Tim Kane
20 posts
#6511 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

Looks pretty solid, I haven't noticed anything amiss that hasn't already been mentioned.

This might be asking a bit much, and I can live without it, but...
Is there any intention to have the original forum topic URL's redirect to their new URL's?

I've a few dozen posts I'd bookmarked to read later when I had the headspace, but they're not so useful now. Maybe I'm the only one that still uses bookmarks.

I was hoping to just hack the URL and use the old post id's, but it seems they were renumbered in the shift.
ChronalDragon
Andrew Chronister
184 posts
2 projects

Developer, administrator, and style wrangler

#6512 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

TimRex

This might be asking a bit much, and I can live without it, but...
Is there any intention to have the original forum topic URL's redirect to their new URL's?

I've a few dozen posts I'd bookmarked to read later when I had the headspace, but they're not so useful now. Maybe I'm the only one that still uses bookmarks.



The only reason this does not already work is because we had more pressing issues to deal with yesterday. Your old URLs will work again soon.
ChronalDragon
Andrew Chronister
184 posts
2 projects

Developer, administrator, and style wrangler

#6513 The Handmade.Network Feedback Megathread!
1 year, 4 months ago Edited by Andrew Chronister on April 26, 2016, 7:01 p.m.

mmozeiko
dmade.network/static/light/empty-avatar.svg image from https address. Otherwise no green padlock on address bar. Don't make absolute URL's. Make them relative to root or a least to protocol: //handmade.network/static/light/empty-avatar.svg


Done. We were serving it over HTTP because it was previously going through a gravatar service, which was unable to pass through the image over https because of the auth we had up on the preview site.

mmozeiko
Something is wrong with your URL scheme.
Some links lead to https://hmn.handmade.network/... but some links lead to https://handmade.network/... I think I was logged in on hmn.handmade.network site, but not on handmade.network site and it was strange. When going over pages suddenly I'm logged in, and after few links I'm logged out, and a bit later I'm logged in again. Very confusing.


I've made the url generator ignore the subdomain part if it equals 'hmn'. Hopefully that should help.

You shouldn't be getting logged out on different subdomains, but we might have to double check that the cookies are being set properly to work everywhere. Can I ask what browser you're using, and what your cookie settings are? Might help us debug.
Kelimion
Jeroen van Rijn
235 posts
3 projects

A big ball of Wibbly-Wobbly, Timey-Wimey _stuff_

#6514 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

TimRex
Looks pretty solid, I haven't noticed anything amiss that hasn't already been mentioned.

This might be asking a bit much, and I can live without it, but...
Is there any intention to have the original forum topic URL's redirect to their new URL's?

I've a few dozen posts I'd bookmarked to read later when I had the headspace, but they're not so useful now. Maybe I'm the only one that still uses bookmarks.

I was hoping to just hack the URL and use the old post id's, but it seems they were renumbered in the shift.


When I imported the old forums, I left out any deleted threads, posts and members (spam) and renumbered things monotonically. I have kept a mapping of old id's to new id's, and when I have a little bit of time I'll add a redirect from old urls to new urls.
serge_rgb
Sergio González
31 posts
1 project

I'm working on Milton, a paint program with infinite canvas. My mom thinks I'm awesome.

#6519 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

Hopefully I am not reporting this redundantly.
Is anyone else having problems using the site from Firefox (Beta) on Windows? I can't click on the menu bar elements.
ChronalDragon
Andrew Chronister
184 posts
2 projects

Developer, administrator, and style wrangler

#6521 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

serge_rgb
Hopefully I am not reporting this redundantly.
Is anyone else having problems using the site from Firefox (Beta) on Windows? I can't click on the menu bar elements.


I've installed firefox beta and could repro. It looked like a bug in FF...

Until my main firefox updated itself to 46.0 and now it happens there as well.

I'll look into it, it does seem to be buggy behavior in firefox, though. Earlier versions handled the parallax effect fine in terms of picking elements, and Chrome handles it fine as well. I'll have to find a work-around. The landing page should be the only thing that's affected? I didn't see any other issues while I was testing in the FF beta.
TimRex
Tim Kane
20 posts
#6522 The Handmade.Network Feedback Megathread!
1 year, 4 months ago Edited by Tim Kane on April 26, 2016, 10:46 p.m. Reason: broken link

Looks perhaps like the Handmade Hero "Game" sub-forum is missing its earliest post.

The very earliest topic, "The Game!" is 404'ing
Kelimion
Jeroen van Rijn
235 posts
3 projects

A big ball of Wibbly-Wobbly, Timey-Wimey _stuff_

#6523 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

TimRex
Looks perhaps like the Handmade Hero "Game" sub-forum is missing its earliest post.

The very earliest topic, "The Game!" is 404'ing


Fixed. T'was not that the thread was missing, but something else.
mmozeiko
Mārtiņš Možeiko
1477 posts
1 project
#6525 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

Going into forum and clicking on last post date for some topic on right side doesn't go to last post in the topic. Clicking on » symbol works though.
Kelimion
Jeroen van Rijn
235 posts
3 projects

A big ball of Wibbly-Wobbly, Timey-Wimey _stuff_

#6526 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

mmozeiko
Going into forum and clicking on last post date for some topic on right side doesn't go to last post in the topic. Clicking on » symbol works though.


Fixed. Thanks :)
Also, if you hover over either the last post date or » symbol, you get a little preview of that post.
joesavage
Joe Savage
6 posts
1 project
A Computer Science student and software developer from England.
#6527 The Handmade.Network Feedback Megathread!
1 year, 4 months ago Edited by Joe Savage on April 27, 2016, 4:53 a.m.

As search is not yet implemented I'm unsure if this has already been mentioned, but browsing on an rMBP a lot of the images on the site look a little wonky (particularly, project "logo" images on project pages). It would be good if the site had better support for high-DPI displays (e.g. serving 2x images for retina displays).
dgm
David
3 posts
#6528 The Handmade.Network Feedback Megathread!
1 year, 4 months ago

I can't change my profile picture :/

Firefox 45.0.2 on Windows 7 64 bits if that helps :)